Project

Profile

Help

Task #6997

Chef fails to install resource 'yum_package[net-tools]'

Added by Mark Zaslavskiy over 5 years ago. Updated over 5 years ago.

Status:
Duplicated
Priority:
Normal
Assignee:
Alexander Kaluzhny
Category:
mariadb testing
Sprint/Milestone:
Start date:
13.05.2016
Due date:
% Done:

0%

Estimated time:
Target branch:
Test scenario:

Description

I'm seeing the following error when trying to set up a CentOS 7 environment. I believe this started happening on Friday.

INFO:  > node3: Starting Chef Client, version 12.10.38
INFO: > node3: [2016-05-09T01:07:11-04:00] INFO: * Chef 12.10.38 *
INFO: > node3: [2016-05-09T01:07:11-04:00] INFO: Platform: x86_64-linux
INFO: > node3: [2016-05-09T01:07:11-04:00] INFO: Chef-client pid: 15822
INFO: > node3: [2016-05-09T01:07:13-04:00] INFO: Setting the run_list to ["role[node3]"] from CLI options
INFO: > node3: [2016-05-09T01:07:13-04:00] INFO: Run List is [role[node3]]
INFO: > node3: [2016-05-09T01:07:13-04:00] INFO: Run List expands to [mdbc]
INFO: > node3: [2016-05-09T01:07:13-04:00] INFO: Starting Chef Run for vagrant-6f0bf3af
INFO: > node3: [2016-05-09T01:07:13-04:00] INFO: Running start handlers
INFO: > node3: [2016-05-09T01:07:13-04:00] INFO: Start handlers complete.
INFO: > node3: Installing Cookbook Gems:
INFO: > node3: Compiling Cookbooks...
INFO: > node3: Platform family: rhel
INFO: > node3: Platform version: 7.1.1503
INFO: > node3: Converging 12 resources
INFO: > node3: Recipe: mariadb::mdbcrepos
INFO: > node3: * yum_package[net-tools] action install
INFO: > node3:
INFO: > node3:
INFO: > node3: ================================================================================
INFO: > node3: Error executing action `install` on resource 'yum_package[net-tools]'
INFO: > node3: ================================================================================
INFO: > node3:
INFO: > node3: NoMethodError
INFO: > node3: -------------
INFO: > node3: undefined method `length' for nil:NilClass
INFO: > node3:
INFO: > node3: Resource Declaration:
INFO: > node3: ---------------------
INFO: > node3: # In /tmp/vagrant-chef/5647e9fbc8a74e8fe1cfa518d9f38f42/cookbooks/mariadb/recipes/mdbcrepos.rb
INFO: > node3:
INFO: > node3: 5: package pkg
INFO: > node3: 6: end
INFO: > node3:
INFO: > node3: Compiled Resource:
INFO: > node3: ------------------
INFO: > node3: # Declared in /tmp/vagrant-chef/5647e9fbc8a74e8fe1cfa518d9f38f42/cookbooks/mariadb/recipes/mdbcrepos.rb:5:in `block in from_file'
INFO: > node3:
INFO: > node3: yum_package("net-tools") do
INFO: > node3: package_name "net-tools"
INFO: > node3: action [:install]
INFO: > node3: retries 0
INFO: > node3: retry_delay 2
INFO: > node3: default_guard_interpreter :default
INFO: > node3: declared_type :package
INFO: > node3: cookbook_name :mariadb
INFO: > node3: recipe_name "mdbcrepos"
INFO: > node3: flush_cache {:before=>false, :after=>false}
INFO: > node3: end
INFO: > node3:
INFO: > node3: Platform:
INFO: > node3: ---------
INFO: > node3: x86_64-linux
INFO: > node3:
INFO: > node3: [2016-05-09T01:07:14-04:00] INFO: Running queued delayed notifications before re-raising exception
INFO: > node3:
INFO: > node3: Running handlers:
INFO: > node3: [2016-05-09T01:07:14-04:00] ERROR: Running exception handlers
INFO: > node3: Running handlers complete
INFO: > node3: [2016-05-09T01:07:14-04:00] ERROR: Exception handlers complete
INFO: > node3: Chef Client failed. 0 resources updated in 03 seconds
INFO: > node3: [2016-05-09T01:07:14-04:00] FATAL: Stacktrace dumped to /var/chef/cache/chef-stacktrace.out
INFO: > node3: [2016-05-09T01:07:14-04:00] FATAL: Please provide the contents of the stacktrace.out file if you file a bug report
INFO: > node3: [2016-05-09T01:07:14-04:00] ERROR: yum_package[net-tools] (mariadb::mdbcrepos line 5) had an error: NoMethodError: undefined method `length' for nil:NilClass
INFO: ==> node3: [2016-05-09T01:07:14-04:00] FATAL: Chef::Exceptions::ChildConvergeError: Chef run process exited unsuccessfully (exit code 1)

It doesn't happen with Ubuntu which first led me to believe it was a network error with the CentOS repositories. After looking at the build logs I think it's something else as usually the logs seem to have a different message when the failure is caused by a network error.

The failures are somewhat problematic as all our testing backends use CentOS 7 as the base distribution. If there's anything I can help with (logs etc.), please let me know.

Markus

History

#1 Updated by Mark Zaslavskiy over 5 years ago

  • Status changed from New to Duplicated

Also available in: Atom PDF