Project

Profile

Help

Bug #6653

server.cnf is not going to the MySQL node

Added by Timofey Turenko over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Immediate
Category:
-
Sprint/Milestone:
Start date:
21.01.2016
Due date:
24.01.2016
% Done:

100%

Estimated time:
Target branch:
Test scenario:

Description

Node description:

"node0" :
  {
"hostname" : "node0",
"box" : "centos_7.0_libvirt",
"product" : {
"name": "mysql",
"version": "5.6",
"cnf_template" : "server1.cnf",
"cnf_template_path": "~/build-scripts/test-setup-scripts/cnf"
}
}

Expected result:
server1.cnf is copied to the node

Actual result: /etc/my.cnf.d is empty

History

#1 Updated by Kirill Yudenok over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Kirill Yudenok

#2 Updated by Kirill Yudenok over 4 years ago

  • Status changed from Assigned to Active / In progress

#3 Updated by Kirill Yudenok over 4 years ago

  • Due date set to 23.01.2016

#4 Updated by Kirill Yudenok over 4 years ago

  • Due date changed from 23.01.2016 to 24.01.2016
  • create pull request only for centos platform
  • #6654 task new pull request for debian & ubuntu platforms

#5 Updated by Kirill Yudenok over 4 years ago

  • Status changed from Active / In progress to Pull request
  • Assignee changed from Kirill Yudenok to Alexander Kaluzhny

#6 Updated by Kirill Yudenok over 4 years ago

  • Status changed from Pull request to Ask for information
  • Assignee changed from Alexander Kaluzhny to Timofey Turenko

#7 Updated by Timofey Turenko over 4 years ago

I will check. Probably there is some difference in DB server start/stop commands. Also I've updated build scripts.

#8 Updated by Timofey Turenko over 4 years ago

  • Status changed from Ask for information to Active / In progress
  • Assignee changed from Timofey Turenko to Kirill Yudenok

The problem is that adding includedir is commented out for some reason in Mysql recipe:

when "rhel", "fedora", "centos", "suse", "opensuse" 
  1. /etc/my.cnf.d -- dir for *.cnf files
    copycmd = 'cp /home/vagrant/cnf_templates/' + node['mysql']['cnf_template'] + ' /etc/my.cnf.d'
    execute "Copy mdbci_server.cnf to cnf_template directory" do
    command copycmd
    end
  1. TODO: check if line already exist !!!
    #addlinecmd = "replace '!includedir /etc/my.cnf.d' '!includedir " + node['mariadb']['cnf_template'] + "' -- /etc/my.cnf"
    #execute "Add mdbci_server.cnf to my.cnf includedir parameter" do # command addlinecmd
    #end

It is the reason why MySQL does not take server1.cnf into use and it is not possible to setup Master/Slave (binary logging is disabled by default in MySQL)

#9 Updated by Kirill Yudenok over 4 years ago

  • Sprint/Milestone changed from 0.82 to 0.83

#10 Updated by Kirill Yudenok over 4 years ago

  • Sprint/Milestone changed from 0.83 to 0.82

#11 Updated by Kirill Yudenok over 4 years ago

  • Assignee changed from Kirill Yudenok to Timofey Turenko

#12 Updated by Timofey Turenko over 4 years ago

is it fixed?
It is assigned to me, smoke testing is done, but status is "IN progress"

#13 Updated by Kirill Yudenok over 4 years ago

  • Status changed from Active / In progress to Testing
  • % Done changed from 0 to 100

#14 Updated by Timofey Turenko over 4 years ago

  • Status changed from Testing to Pull request
  • Assignee changed from Timofey Turenko to Kirill Krinkin

works, server.cnf is in proper place, my.cnf contains reference to my.cnf.d.
Please integrate.

#15 Updated by Kirill Yudenok over 4 years ago

  • Status changed from Pull request to Closed

Also available in: Atom PDF